WordPress更新插件需要FTP权限的问题

By | 2012 年 4 月 19 日

WordPress在发现其所在目录的所有者和进程所有者不一致时会跳转到一个页面让填写ftp信息。解决办法如下:

运行
ps -aux
查看httpd进程或者apache2进程的用户名,比如我看见是www-data

切换到Wordpress的安装路径,比如wordpress安装在位置/www/wordpress ,就切换到/www目录,执行:
chown -R www-data:www-data wordpress

然后就OK了。

发表评论

电子邮件地址不会被公开。 必填项已用*标注