旧项目在iOS6中链接不过的问题,提示缺armv7s

By | 2012 年 10 月 1 日

升级了xcode之后,支持iOS6和iPhone5,不过Build项目的时候,出现错误提示信息:

ld: file is universal (3 slices) but does not contain a(n) armv7s slice

实际上是引用的第三方库导致了这个链接错误。

解决办法有三个,随便哪种都能解决:
1.升级涉及到的.a文件
2.在target的Build Settings里面,将Build Active Architecture Only改成YES
3.在target的Build Settings里面,找到Valid Architectures,删除其中的armv7s

所以还是觉得,如果是开源库,直接把源代码包含进项目比较靠谱。

发表评论

电子邮件地址不会被公开。 必填项已用*标注